Ford F150 Forumz banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
When I'm taking off after just starting the truck it sputters and coughs like a carborated engine. While I'm driving it misses, losses power and the check engine light comes on. Then it straightens up and runs normal. Occasionally well it is idle the check engine light will come on and it will die. Any comments will be appreciated.
 

·
Premium Member
2013 F-150 XLT 4WD with 5L
Joined
·
1,775 Posts
First off, welcome to the forum!

You need to capture the codes from the on board diagnostic system (ODBS) so we can see what is going on. Far too many things can cause that kind of behavior. Most auto parts stores have readers on-hand and will gladly read the codes for you for free.

Mac
 

·
Registered
Joined
·
13 Posts
I am watching this one .. it seems to relate to mine, pretty close.
I was not getting the check engine light on mine until recently.
I have the most trouble on wet days.
It will run with the miss/sputter, but; under heavy throttle and at higher RPM runs better..

Talked with a gent who has a 95,2Wd, 302; - described same basic syptoms - he changed his distributor and has not since had the problem...
any thoughts??

It will start, idle and run on dry days but will surge and choke out at times. Worse on wet days.

Merry Christmas to All !
 

·
Registered
Joined
·
2 Posts
Hey all! New to the community. I'm having the exact same symptoms as well. This has been a thorn in my side for about a year. I've replaced the o2 sensor twice, air filter put in stabilizer. Up next i'm going to check the PCV valve and manifold vacuum hose. You might want to try those out. If anybody has any other suggestions please bump this thread.
I have a 1994 F150 easter egg blue/green truck made in Cali with 370,000 miles on it, and It's stalled a couple of time on me in drive-thrus and once in bumper to bumper traffic on a highway. It also tries to die on the highway when i'm steady at 65. I have to floor the throttle to get her going smooth again but it doesn't always work.

NOTE* there's also a ticking sound coming from the driver's side of the engine. When that ticking sound happens the engine weakens with every tick. Probably a blown gasket but it's impossible to get to without taking the engine out
 
1 - 4 of 4 Posts
Top