Ford F150 Forumz banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have started to get missfire codes on my truck, first was a cyl 5 and then on cyl 4.
I did get the flashing CEL and it reset once I shut off the engine and restarted.
Truck has 207K miles and is a manual, the flashing CEL was in 5th gear and low load.
This may be related, I have a coolant leak I can not find.

The smell of raw coolant is around the truck and no smoke out the exhaust or any trace of it in the engine oil.
I do have 2 new coil packs and wires along with plugs.
What has me even more puzzled is that cyl 5 and 4 are coming up, different side of the engine.
Any help is appreciated.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Update

Well I replaced both coilpacks and found that 2 plug wire sockets have a lot of green corrosion in one and the other show evidence of spark jumping and eroded the plastic case.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I finaly took my truck to my mechanic and told him what was going on.
He diagnosed the short and long fuel trim are way out and replaced the plugs since i was unable.
Along with this I asked him to address the radiator that was clogged with crud.
I got the truck back yesterday and bamm i get a missfire again on cyl 5.
engine is a 4.6, 207K miles on it, came across a youtube post today about the intake gaskets leaking fluid either into the intake valve or the spark plug bore.
Has anyone had this problem?
 
1 - 3 of 3 Posts
Top