Ford F150 Forumz banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1997 Ford F150 pick-up with 132,000 miles. It was purchased in 1997 and has been a great, dependable truck. However, while driving today I noted that my cruise control doesn't work. Also, my airbag light stays lit all the time. Could these be related to the same cause?

Any input would be appreciated...
 

·
FORD F150 FORUM
Joined
·
200 Posts
Welcome to the club!
It could very well be an electrical issue that has effected both. I'd take it to the dealer.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the reply but I think I would like to check the fuse out first. Any idea where the fuses are located? I found one box under the hood, but nothing for the horn in there! HELP!
 

·
Registered
Joined
·
1,752 Posts
Welcome to the forum!

The two issues should not be at all related as they are on separate circuits. Some things you can look at after the usual fuse search is the vehicle speed sensor and the servo. The switch itself can be at issue as well. Do you get any indication that the system is working at all (i.e. green CC light comes on even if the system isn't working)?

As for your air bag light it could be an SRS module failure ,or an individual crash sensor may be malfunctioning. Either way, this is something that needs to be looked at.

Don't forget, you can always head over to one of the major auto parts stores and get them to see if any codes were generated, that would surely help isolate your troubles.

Mac

 
1 - 4 of 4 Posts
Top