Ford F150 Forumz banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My sons F150, 2001, just started running very rough as if it wasn't firing on a cylinder. Replaced plugs and wires still running rough AND I noticed that the cat gets red hot (driver side). Got bank 2 lean error code. Any suggestions??

Thanks in advance for the help!
 

·
Registered
Joined
·
1,752 Posts
Sounds like the cat might be plugged. A catalytic convertor should never glow red hot.

As for bank 2 running lean, that simply means that the O2 sensor detected too much oxygen in the exhaust gas and can manifest itself with symptoms such as a lack of power, detonation (spark knock), and/or a hesitation/surge on acceleration.

Possible solutions include:

  • In many cases, cleaning the mass air flow (MAF) sensor fixes the problem. I find it's best to take it off and spray it with electronics cleaner or brake cleaner. Make sure you are careful not to damage the MAF sensor, and make sure it's dry before reinstalling
  • Inspect all vacuum and PCV hoses, replace if necessary
  • Check for a dirty fuel filter and proper fuel pressure
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3 (Edited)
I have cleaned the MAF, after reading similar posts, still running rough. The cat doesn't seem to be getting as hot as it did. I will check the vacuum hoses etc. There seems to be a strange smell coming from the exhaust, with what seems to be a lot of condensation. Not sure if that means anything to you.

Thank you for your response, it is very much appreciated!
 
1 - 3 of 3 Posts
Top