Ford F150 Forumz banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi Guys and Gals,

I recently purchased a 1997 F150 4.2 Liter. On the way home it started missing. Within the next few days it died on the side of the road. After towing home I found no spark. A few days later I t started but only for a few minuites and died. No spark, coil pack is new so I replaced the CKP and it started up. Drove it about 1/2 Mile and died again, No spark again. Not getting power to coil pack when I am turning it over. So in short, new coil pack and CKP sensor and no spark. If it sits for a few days it may start or it may not. But if it does it only runs for a short period and then no spark again. Any help sure would be appreciated.

Best
 

·
Registered
Joined
·
1,752 Posts
The coil packs get power from three sources off the PCM. Of the for wires going to the coil pack, the one that is red/light green goes to the PCM power diode. Have you verified that the wires going to the coil pack are all good with no breaks or shorts?

It may be a PCM issue. Those go for about $170 to $200.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
The coil packs get power from three sources off the PCM. Of the for wires going to the coil pack, the one that is red/light green goes to the PCM power diode. Have you verified that the wires going to the coil pack are all good with no breaks or shorts?

It may be a PCM issue. Those go for about $170 to $200.
The wire on the far right of the coil plug has power to it, but the other three dont have the negative pulse when it is turned over.
 

·
Registered
Joined
·
1,752 Posts
Here is the wiring schematic (1 of 4)...

 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
still n spark

Thanks for the help, I tried switching relays, still nothing, Truck did start earlier in the day and ran for aout ten seconds and then no spark again, When i am turning it over I am hearing a ticking noise on every revolution like something is trying to tell it to spark and when it catches it starts momentarily. It sounds like it is on the passenger side but cant tell where exactly do to turning over the engine and trying to hear it over the noise. Any ideas. Or is the noise something I am unaware of that is suposed to be there?
 

·
Registered
Joined
·
1,752 Posts
Have you tried to retrieve any codes from the PCM to help isolate this problem?
 
1 - 9 of 9 Posts
Top